teachmeoracle.com
Site Dedicated to Oracle Apps DBA's
 
    SearchSearch    ProfileProfile    RegisterRegister   Log inLog in 
For Quality Online Oracle Apps 11i/R12 training (DBA, Apps DBA, PL/SQL, OA Framework, Payroll and many more) visit focusThread.com/training

RW-50004 Error code received when runing external process.

 
Post new topic   Reply to topic    teachmeoracle.com Forum Index -> Installation Issues for Apps
View previous topic :: View next topic  
Author Message
pralhad
Junior Member
Junior Member


Joined: 25 Oct 2006
Posts: 26
Location: Bangalore

PostPosted: Tue Sep 08, 2009 10:39 am    Post subject: RW-50004 Error code received when runing external process. Reply with quote

Hi Atul

Please help me , Since 15 days i am trying to install and not able to do it.

I am trying to install Oracle apps 12i on RHEL 5. I have installed all prerequsit RPM pakages before runing oracle apps installation.

I have renamed gcc and g++ and linked as below

mv /usr/bin/gcc /usr/bin/gcc.org
mv /usr/bin/g++ /usr/bin/g++.org

ln -s/usr/bin/i386-redhat-linux-gcc32 /usr/bin/gcc
ln -s/usr/bin/i386-redhat-linux-g++32 /usr/bin/g++

I am getting error - RW-50004 Error code received when runing external process. Check log file for details. Runing Database install Driver for VIS instance.

error log
Statusstring Configuring Database

Executing command: /ora/u01/StageR12/startCD/Disk1/rapidwiz/jre/Linux/1.5.0//bin/java -DCONTEXT_VALIDATED=true -mx512M -classpath /ora/u01/StageR12/startCD/Disk1/rapidwiz/jlib/java:/ora/u01/StageR12/startCD/Disk1/rapidwiz/jlib/xmlparserv2.jar:/ora/u01/StageR12/startCD/Disk1/rapidwiz/jlib/ojdbc14.jar:/ora/u01/StageR12/startCD/Disk1/rapidwiz/jlib/oui/OraInstaller.jar:/ora/u01/StageR12/startCD/Disk1/rapidwiz/jlib/oui/ewt3.jar:/ora/u01/StageR12/startCD/Disk1/rapidwiz/jlib/oui/share.jar:/ora/u01/StageR12/startCD/Disk1/rapidwiz/jlib/oui/srvm.jar oracle.apps.ad.clone.ApplyDatabase -e /ora/d01/oracle/VIS/db/tech_st/10.2.0/appsutil/VIS_sakee21.xml -stage /ora/u01/StageR12/startCD/Disk1/rapidwiz -showProgress -phase cfg -nopromptmsg

Log file located at /ora/d01/oracle/VIS/db/tech_st/10.2.0/appsutil/log/VIS_sakee21/ApplyDatabase_09081600.log

^M
| 0% completed ^M
| 0% completed ^M
/ 0% completed ^M
- 0% completed ^M
\ 0% completed ^M
| 0% completed ^M
/ 0% completed RC-50004: Fatal: Error occurred in ApplyDatabase:

Control file creation failed

Cannot execute configure of database using RapidClone

RW-50010: Error: - script has returned an error: 1
RW-50004: Error code received when running external process. Check log file for details.
Running Database Install Driver for VIS instance

---------------------------------------------------------------
ADX Database Utility
---------------------------------------------------------------

getConnection() -->
sDbHost : sakee21
sDbDomain : sakee.com
sDbPort : 1521
sDbSid : VIS
sDbUser : APPS
Trying to connect using SID...
getConnectionUsingSID() -->
JDBC URL: jdbc:oracle:thin:@sakee21.sakee.com:1521:VIS
Exception occurred: java.sql.SQLException: ORA-01034: ORACLE not available
ORA-27101: shared memory realm does not exist
Linux Error: 2: No such file or directory

Trying to connect using SID as ServiceName
getConnectionUsingServiceName() -->
JDBC URL: jdbc:oracle:thin:@(DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=sakee21.sakee.com)(PORT=1521))(CONNECT_DATA=(SERVICE_NAME=VIS)))
Exception occurred: java.sql.SQLException: Listener refused the connection with the following error:
ORA-12514, TNS:listener does not currently know of service requested in connect descriptor
The Connection descriptor used by the client was:
(DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=sakee21.sakee.com)(PORT=1521))(CONNECT_DATA=(SERVICE_NAME=VIS.sakee.com)))

Connection could not be obtained; returning null


Please kindly provide me solution for for this as ealy as as possible,

Thanks
Pralhad
_________________
Prlahad
Back to top
View user's profile Send private message Yahoo Messenger
SubbaRao
Member of The Month
Member of The Month


Joined: 13 Nov 2006
Posts: 902

PostPosted: Tue Sep 08, 2009 11:38 am    Post subject: Reply with quote

Hi,

what R12 Version you are installing?

what is the Rapidwiz version?

Are you installing from Stage Area or from DVD?


Regards,
Subbu
Back to top
View user's profile Send private message
pralhad
Junior Member
Junior Member


Joined: 25 Oct 2006
Posts: 26
Location: Bangalore

PostPosted: Tue Sep 08, 2009 1:39 pm    Post subject: Reply with quote

HI Subbu

what R12 Version you are installing?
Yes i am installing R12

what is the Rapidwiz version?
Oracle Applications Rapid Install Wizard
Version 12.0.0.21

Are you installing from Stage Area or from DVD?

From stage area i am installing.

Please help and what could be the problem.

Thanks
Pralhad
_________________
Prlahad
Back to top
View user's profile Send private message Yahoo Messenger
prakash_nihalani



Joined: 30 Mar 2008
Posts: 21

PostPosted: Tue Sep 08, 2009 6:18 pm    Post subject: Reply with quote

Please check $ORACLE_HOME/lib and $ORACLE_HOME/lib32 files and make sure softlinks are pointing to correct location. If not , delete and create correct softlinks.
_________________
Prakash Nihalani
Back to top
View user's profile Send private message
SubbaRao
Member of The Month
Member of The Month


Joined: 13 Nov 2006
Posts: 902

PostPosted: Wed Sep 09, 2009 3:24 am    Post subject: Reply with quote

Pralhad,

R12 Version Means? what is your 3 digit version?

I mean, is it 12.0.4 or 12.0.6 etc?

By the way, did you apply all the RPM's before installation? please check the installation notes for Linux and apply all Required RPM's as per the note.


Regards,
Subbu
Back to top
View user's profile Send private message
pralhad
Junior Member
Junior Member


Joined: 25 Oct 2006
Posts: 26
Location: Bangalore

PostPosted: Wed Sep 09, 2009 4:10 am    Post subject: Reply with quote

Hi Prakash

Thanks for your reply. there is no lib32 folde in ORACLE_HOME only ORACLE_HOME/lib folder is present.

Please let me know what could could be the problem.

Thanks
Pralhad
_________________
Prlahad
Back to top
View user's profile Send private message Yahoo Messenger
SubbaRao
Member of The Month
Member of The Month


Joined: 13 Nov 2006
Posts: 902

PostPosted: Thu Sep 10, 2009 8:17 am    Post subject: Reply with quote

Hi,

I think, there is nothing to do with gcc or lib packages......

try the below

(a) Wipe out the previous installation and global inventory

(b) Try with the latest rapidinstaller version Patch 6919017. appy this patch on stage area. you can see the patch readme file for application of this patch.

(c) start the installation again

If it does not work, stage the R12 cd's again and let us know, we will contine to work on this
Back to top
View user's profile Send private message
pralhad
Junior Member
Junior Member


Joined: 25 Oct 2006
Posts: 26
Location: Bangalore

PostPosted: Fri Sep 11, 2009 11:35 am    Post subject: Reply with quote

Hi All

I am installing oracle apps R12 on Linux RHEL 4 . Installation completed sucessfully. post installation i am getting below errors.

Please help me.

ADX Database Utility
---------------------------------------------------------------

getConnectionUsingAppsJDBCConnector() -->
APPS_JDBC_URL='null'
Trying to get connection using SID based connect descriptor
getConnection() -->
sDbHost : sakee40
sDbDomain : sakee.com
sDbPort : 1521
sDbSid : VIS
sDbUser : APPS
Trying to connect using SID...
getConnectionUsingSID() -->
JDBC URL: jdbc:oracle:thin:@sakee40.sakee.com:1521:VIS
Connection obtained

-------------------ADX Database Utility Finished---------------
Successful upload of config file at /tmp/09111656/conf_VIS.txt
Environment File

-----------------
Database ORACLE_HOME environment file passes instantiated variables test:
File = /ora/d01/oracle/VIS/db/tech_st/10.2.0/VIS_sakee40.env

Apps ORACLE_HOME environment file passes instantiated variables test:
File = /ora/d01/oracle/VIS/inst/apps/VIS_sakee40/ora/10.1.3/VIS_sakee40.env

iAS ORACLE_HOME environment file passes instantiated variables test:
File = /ora/d01/oracle/VIS/inst/apps/VIS_sakee40/ora/10.1.2/VIS_sakee40.env
APPL_TOP environment file passes instantiated variables test:
File = /ora/d01/oracle/VIS/apps/apps_st/appl/VIS_sakee40.env

ADOVARS environment file passes instantiated variables test:
File = /ora/d01/oracle/VIS/apps/apps_st/appl/admin/adovars.env

APPSCONFIG passes instantiated variables test:
File = /ora/d01/oracle/VIS/apps/apps_st/appl/admin/adconfig.txt

DBC File
---------
DBC file passes instantiated variables test:
File = /ora/d01/oracle/VIS/inst/apps/VIS_sakee40/appl/fnd/12.0.0/secure/VIS.dbc

HTTP

-----


checking URL = http://sakee40.sakee.com:8000

RW-50015: Error: - HTTP Listener is not responding. The service might not have started on the port yet. Please check the service and use the retry button.
Help Page

----------
checking URL = http://sakee40.sakee.com:8000/OA_HTML/help

RW-50015: Error: - Help Page is not responding. The service might not have started on the port yet. Please check the service and use the retry button.
Virtual Directory

------------------
RW-50015: Error: - Http Server Virtual Directories is not responding. The service might not have started on the port yet. Please check the service and use the retry button.
JSP

----


checking URL = http://sakee40.sakee.com:8000/OA_HTML/jtfTestCookie.jsp

RW-50015: Error: - JSP is not responding. The service might not have started on the port yet. Please check the service and use the retry button.
Login Page

-----------

RW-50015: Error: - Login Page is not responding. The service might not have started on the port yet. Please check the service and use the retry button.

Pls let me know how to resollve this issue..

Thanks
Pralhad
_________________
Prlahad
Back to top
View user's profile Send private message Yahoo Messenger
SubbaRao
Member of The Month
Member of The Month


Joined: 13 Nov 2006
Posts: 902

PostPosted: Sat Sep 12, 2009 10:04 am    Post subject: Reply with quote

Hi,

was installation successfull apart from the startup errrors,that what you have provided here.

if installation was successfull.

(a)stop the applicaiton services ( don't shutdown the db and listener)

(b) please run the autoconfig on db tier and make sure that it is completed successfully

(b) after that run the autoconfig on application tier and make sure that it is run successfully

(c) start the application services again and see the status of the apache server

if stil you get the same issue, please post the complete error log of apache server


Regards,
Subbu
Back to top
View user's profile Send private message
pralhad
Junior Member
Junior Member


Joined: 25 Oct 2006
Posts: 26
Location: Bangalore

PostPosted: Mon Sep 14, 2009 4:57 am    Post subject: Reply with quote

Hi Subbu

Thanks for your reply. I have resolved the issue its working fine.

Thanks for all of your support on time.

Regards
Pralhad
_________________
Prlahad
Back to top
View user's profile Send private message Yahoo Messenger
SubbaRao
Member of The Month
Member of The Month


Joined: 13 Nov 2006
Posts: 902

PostPosted: Mon Sep 14, 2009 6:42 am    Post subject: Reply with quote

Hi Pralhad,

That is nice that you have resolved the issue.

Could you please share the things here, that you did to resolve the issue?

Regards,
Subbu
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    teachmeoracle.com Forum Index -> Installation Issues for Apps All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by becomeAppsDBA.blogSpot.com © 2006, 2007 TeachMeOracle Group